RStudio fresh install launches but unresponsive in macOS Catalina

Description of issue -

Hello, I'm a brand new R user and just tried downloading R and RStudio fresh. R seems to be working as anticipated. RStudio will open, but will be entirely unresponsive to any commands I type in the console. For example, when I press 'enter' after the following:


The cursor progresses to the next line but there is not output on the screen. RStudio is otherwise also completely unresponsive to clicking other buttons, and the entire window soon turns black without the app actually crashing, requiring a force quit.

I have tried uninstalling and reinstalling R (4.0 CRAN notarized) and RStudio (1.2.5 and preview versions) multiple times, including using app removal software AppZapper.

When I run a diagnostics report, I get the following error:
29 Apr 2020 12:52:57 [rsession-bluestreak32] ERROR r error 4 (R code execution error) [errormsg=]; OCCURRED AT: rstudio::core::Error rstudio::r::exec::executeSafely(boost::function<void ()>) /Users/vagrant/workspace/IDE/macos-v1.2/src/cpp/r/RExec.cpp:224; LOGGED FROM: void rstudio::session::(anonymous namespace)::processEvents() /Users/vagrant/workspace/IDE/macos-v1.2/src/cpp/session/SessionHttpMethods.cpp:98
29 Apr 2020 13:10:17 [rsession-bluestreak32] WARNING file monitor thread didn't stop on its own; LOGGED FROM: void rstudio::core::system::file_monitor::stop() src/cpp/core/system/file_monitor/FileMonitor.cpp:637

Any ideas would be appreciated! Thank you

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 1.2.5042
  • OS Version: macOS Catalina 10.15.4
  • R Version: 4.0.0 (CRAN notarized)
  • sessionInfo():

Referred here from

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.