Rstudio IDE desktop 2022.02.0-443 not working on ubuntu 22.04 LTS, some GUI issue?

Hello,
I am trying to install Rstudio desktop( rstudio-2022.02.0-443-amd64.deb) on linux 22.04 LTS with R 4.2.0 using gdebi-core approach from here but failing.

libssl.1.XX

I was running into a problem with the unavailability of libssl.1.0.0 etc libraries, but managed to overcome it by this approach:
You can force the installation of libssl1.1 by adding the ubuntu 21.10 source and installed it.
I can see the icon:)

Wayland

However after starting R studio from the terminal the terminal prints:
TTY detected. Printing informational message about logging configuration. Logging configuration loaded from '/etc/xdg/xdg-ubuntu:/etc/xdg/rstudio/logging.conf'. Logging to '/home/vld/.local/share/rstudio/log/rdesktop.log'. Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

The appearence of the Rstudio is a grey box of the IDE with the menu items which are not clickable.

I have tried to set the platform using the export QT_QPA_PLATFORM=wayland but did not help. ie different error messages appeared.

Solution

Can please somebody help me out and/or suggest a combination of a linux distro, R, and R studio IDE which works out of the box/with minimal troubleshooting?
I am super new to linux, so can mostly copy paste the commands into the shell without understanding much.
I am dedicating one older laptop just for this so have no preferences for the distro or R studio IDE version.

Thank you

Vladimir

Up until now, there is no stable release that supports Ubuntu 22.04 LTS, but there is a daily build that already does, you can download it from here

https://dailies.rstudio.com/rstudio/spotted-wakerobin/desktop/jammy/

The latest RStudio IDE stable release officially supports up to Ubuntu 20.04 LTS

4 Likes

Thank you for your reply, will get the 20.04 LTS.
Have a nice day
Vladimir

I have hit this libssl1.1 problem with the stable version of Rstudio and Ubuntu 22.04. The Rstudio daily builds (I'm up to #373) install fine but in the default set up Rstudio is unusably slow. I have found a way around this which may help others but I don't like it and hope that some combination of nVidia (hm), Ubuntu and Rstudio come up with a better solution.

Background
This is on a new machine ("Clevo" with "AMD Ryzen 7 5800H with Radeon Graphics" and "GA106M [GeForce RTX 3060 Mobile / Max-Q]" (from lshw). I had hopeless problems to get this machine to work with an external monitor with the supplied Mint (Cinnamon 20.3 if I remember correctly) which I think confirms what serious Linux geeks may know: that Linux and nVidia aren't always the best dance partners. Anyway, on the advice of the vendor I swapped from Mint to Ubuntu 22.04. That works fine with the external monitor but I hit that impossibility installing the stable Rstuio because of the libssl1.1 issue so I went to the daily builds after reading this information here.

OK. I find this about the system:

# ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.1/0000:01:00.0 ==
modalias : pci:v000010DEd00002520sv00001558sd000070F2bc03sc00i00
vendor   : NVIDIA Corporation
model    : GA106M [GeForce RTX 3060 Mobile / Max-Q]
driver   : nvidia-driver-470 - distro non-free
driver   : nvidia-driver-510-server - distro non-free
driver   : nvidia-driver-510 - distro non-free recommended
driver   : nvidia-driver-470-server - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

# nvidia-smi
Sun May  8 18:13:08 2022       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 510.60.02    Driver Version: 510.60.02    CUDA Version: 11.6     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
| N/A   44C    P5    17W /  N/A |     73MiB /  6144MiB |     34%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A      5030      G   /usr/lib/xorg/Xorg                 69MiB |
|    0   N/A  N/A      5372      G   ...ome-remote-desktop-daemon        2MiB |
+-----------------------------------------------------------------------------+

The daily builds install but the interface is so sluggish it's completely unusable. I got a hint from the fact that Chromium has the same problem (as do a number of other programs but only some, to my mind bafflingly, Ubuntu's disks is another example, and zoom). Clearly something is broken in the use of "hardware acceleration" and switching that off in Chromium (and related programs: Opera & Vivaldi) fixes that. The trick in Rstudio is go to Tools, Options, General, Advanced and under "OS integration" to change "Rendering engine" to "Software" (which I assume is the same as switching off "hardware acceleration" in Chromium). Then things are pretty usable. I hope this helps others! Very best, Chris (and thanks to andresrcs for the pointer to the daily builds)

Thank you @andresrcs
I installed latest version and now RStudio works fine.