RStudio IDE terminal windows still shows a 'busy' status.

Moved from: Cannot use terminal: no window contents

I'm trying to use the terminal windows in RStudio but it shows a 'busy' status in a blank windows.

I tried to closed it, close everything and re-open it and nothing.

I also have tried turning off all the terminal options but doesn't work. My terminal windows still shows a 'busy' status.

Here is what the terminal diagnostic shows:

Global Terminal Information
Loaded TerminalSessions: 1
Handle: '79FB468A' Caption: 'Terminal 2'

Terminal List Count: 1
Handle: '79FB468A' Caption: 'Terminal 2' Session Created: true

Current Terminal Session Information
Caption:     'Terminal 2'
Title:       ''
Cols x Rows  '149 x 31'
Shell:       'Bash'
Handle:      '79FB468A'
Sequence:    '2'
Restarted:   'false
Busy:        'true'
Exit Code:   'null'
Full screen: 'client=false/server=false'
Zombie:      'false'
Track Env    'true'
Local-echo:  'true'
Working Dir: 'Default'
Interactive: 'Always'
WebSockets:  'true'
Typing lag:  '0ms'

System Information
Desktop:    'false'
Platform:   'Mac'
Browser:    'Chrome'

Connection Information
2018/11/26 14:50:35: Connect WebSocket: 'ws://localhost:8787/p/6084/terminal/79FB468A/'
2018/11/26 14:50:35: WebSocket connected

Local-echo Match Failures

and my sessionInfo():

R version 3.4.4 (2018-03-15)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 16.04.5 LTS


You are likely running a shiny app. This app is within your current r session i.e. terminal session. Your terminal should be available as soon as you stop that app.

See documentation here:



Hi @jm_t,

No, this problem happens just when I open the RStudio through a Browser.

I have tried to stop any process behind using the stop bottom or by "Interrupt Current Terminal" but doesn't work, I still have the "busy" status


Then I have no idea. Sorry.

Could be some process started by R as part of the executing some init scripts.
I never used them but I know they exists and can change stuff in R session.



Do you have a custom .bash_profile or similar that might be trying to run code when the shell is initialized that is hanging?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.