Rstudio is invisible and runs only as background process

I am using [RStudio v2021.09.0+351] on Windows 11. The check for update reports that the version is up to date, which it obviously is not.

When I deinstall this version and install the latest version, Installing RStudio-2022.07.1-554 (or RStudio-2022.02.3-492) Rstudio starts as an invisible background process (together with rsession). The only thing I can do is end the process. And reinstall the 2021.09.0 version again.
I have tried all kinds of things, including and RStudio window behaves as if it is invisible
Nothing helps.

In mine RStudio it always says its up-to-date as well. I never understood that.

I think that happened with the switch to calendar-based versioning.

Finally solved! I still don't know the cause. I dismantled my .Rprofile file and the newer 2022 release did start (and was visible). Maybe also interaction with newer R 4.2.1, because after updating to that version I can now use my old .Rprofile and Rstudui still works. Perhaps this can help others.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.