RStudio Server blank screen


#1

Hello all,

RStudio Server just stopped working in the middle of an active session, giving me a blank screen. I tried reloading the page and still got a blank screen. I then cleared my cache, I was taken to the RStudio Server login page as usual; however once I put in my credentials, I was taken back to that same blank screen.

I subsequently tried uninstalling and reinstalling both RStudio Server and R base to no avail. The app is not working properly; rstudio-server verify-installation executes silently and rstudio-server restart returns rsession: no process found

Does anyone have any idea what’s going on? It’s rather upsetting that purging RStudio and reinstalling it is not enough to fix it. My guess is that RStudio can’t find R anymore for some reason, which is weird because I didn’t touch anything, I was in the middle of a session.

Any help, even just general thoughts, would be greatly appreciated.


#2

Can you provide us with a diagnostics report, just in case anything relevant made its way into the error logs?


#3

Uh, how does that work for RStudio Server? I tried sudo rstudio-server --run-diagnostics but that is not a command. I can’t get RStudio to work anymore so I can’t run it from within the application.

I’m on Ubuntu on an Amazon EC2 machine by the way.


#4

You’re right; sorry, I missed that. In that case, do you see any error messages emitted to the system logs when you attempt to launch / connect to RStudio Server? These are usually emitted to one of:

/var/log/syslog
/var/log/messages

Alternatively, you can try launching RStudio Server without daemonizing, so that errors are emitted to the console. If possible, try running RStudio Server with something like:

sudo rstudio-server stop
/usr/lib/rstudio-server/bin/rserver --server-daemonize=0

Then you should (hopefully) see diagnostic information emitted when RStudio fails to launch.


#5

Ok, so there are no error messages there, and I think it’s because there are no errors of which to speak. I have been getting the blank screen intermittently, depending on whether there is a lot of stuff in my local environment. I am able to successfully login, but then there is just a blank screen with no panes or anything, so I can’t delete anything. I guess there’s no solution for that, it’s just a memory bottleneck of some sort for RStudio Server.


#6

I found an error message! Just ran rstudio-server status while getting the blank screen and got this error (which I can’t quote completely):

Feb 15 11:57:45 ip-172-31-3-31 rserver[5211]: CLIENT EXCEPTION (rsession-luis): (TypeError) : undefined is not an object (evaluating 'this.a.a.r.row');|||org/rstudio/studio/client/workbench/views/source/editors/text/r/SignatureToolTipManager.java#134::execute|||com/google/

#7

Unfortunately, that particular error is innocuous – I think it’s unlikely to be related to the blank screen issue you’ve been seeing.

Can you provide a screenshot of what RStudio looks like when it goes blank, just so we know exactly what we’re seeing? (I’m guessing you mean it’s just a blank white window but it would be helpful to see it just so we know exactly what’s going on)

It could be a memory bottleneck if you’re working with very large R objects. If RStudio is attempting to save and load the workspace, and the workspace is very large, perhaps R / RStudio is hanging while attempting to load the workspace?


#8

I get the same issue. In fact, I have always gotten this same issue with RStudio Server. While things initially work, eventually I get a blank screen and nothing seems to work.