RStudio starting, but stuck on loading

I've been using RStudio for some weeks now with no problems, but the last 2 days whenever I open the program, it is stuck on this loading screen. After a while, a pop-up message comes up saying that "The RStudio server takes a long time to respond."

My R version is 3.6.1 and RStudio is 1.2.5019. I added it on the firewall exceptions, I tried to reinstall R and RStudio.

Any suggestions?

Try changing to software rendering, you can change it by holding the Ctrl key while opening RStudio, then you should see this menu and change the "Rendering Engine" to "Software".

You could also try reseting Rstudio's state

Hey, thanks for the reply. I tried that also but it did not work.

You can also try resetting RStudio's state:

It's possible that R / RStudio is hanging while attempting to load an old (very large?) R workspace, or while attempting to render an old R Markdown notebook with a large amount of inline output.

The person above also mentioned that, I tried it but did not work either, unfortunately.

1 Like

Sorry, you're absolutely right and I missed that.

As a last resort, you might try reinstalling both R + RStudio.

I also tried that, I mentioned it in the original post!

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.