RStudio startup error on Fedora 36. Error while loading shared library

Executing rstudio in the terminal gives me the following error: rstudio: error while loading shared libraries: cannot open shared object file: No such file or directory.

I've already tried installing every reasonable variation of OpenSSL, but nothing seems to work. The solution from rubyo 's (closed topic #31380). I tried to troubleshoot it, unsuccessfully, as I described in more detail in the RStudio's Github Issue #12080.

Does someone know what could solve the problem? I'm thinking of just reinstalling Fedora and trying it out again. But it does not seem to be my freshly installed system the cause. I do not want to stop using RStudio over the terminal or alternatives.

System details:

  • R Edition: RStudio Desktop
  • RStudio Version: RStudio 2022.07.2+576 "Spotted Wakerobin"
  • OS Version: Fedora Workstation 36 (kernel: 5.19.12-200.fc36.x86_64)
  • R Version: 4.1.3 (2022-03-10)

Thank you,
My best regards to you all.


Problem solved by jmcphers at the RStudio's GitHub Issues page (mine #12080 and concienciadesventurada's #12083 issues).
The solution is to download the right build to Fedora 36/37 at this link, at this date (2022-10-05) not officially released at the RStudio's download page yet.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.