set RStudio to use git bash shell (MINGW64) rather than Rtools (MSYS) shell??

Using RStudio 1.2.5042, Windows 7, R version 3.6.3

When I run shell ... from the Git tab, I get an MSYS terminal window. But there is something wrong because git is not setup properly here. I also have git bash (MINGW64) installed and this works flawlessly, except
I have to navigate separately to the project directory and run Git Bash Here from the explorer menu.

Here's what I see from MSYS:

   friendly@UIT-HHP-31TRNW1 MSYS /c/R/Rprojects/HistDataVis (master)
   $ git commit -m "fix large image file problems"

   *** Please tell me who you are.


     git config --global ""
     git config --global "Your Name"

   to set your account's default identity.
   Omit --global to set the identity only in this repository.

   fatal: unable to auto-detect email address (got 'friendly@UIT-HHP-31TRNW1.(none)

   friendly@UIT-HHP-31TRNW1 MSYS /c/R/Rprojects/HistDataVis (master)
   $ git add .

   friendly@UIT-HHP-31TRNW1 MSYS /c/R/Rprojects/HistDataVis (master)
   $ git config --global ""
   error: could not lock config file =/.gitconfig: No such file or directory

Can I change an option in RStudio to use MINGW64?
Can I re-configure MSYS so that it works?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.