Should I be able to install binary packages on fedora

I was trying to install rstudio binary packages following but it does not seem to work.

I started R —vanilla and added the rhel 8 repo

options(repos = c(REPO_NAME = ""))

then removed data.table and tried to install again install.packages(“data.table”) but it still installed from sources.
Did I do something wrong? should it work for fedora 32 ?

Many thanks

PS: because binary installs are not done using is package manager I assume I can still install in my local library as my user ?

Hi @statquant_2,

Try renaming the repo to CRAN? You can also double check that your repos have been set correctly by double-checking options('repos').

What is the output of:

options(repos = c(CRAN = ""))

thank you @alexkgold
I solved the issue I had to setup the HTTPAgent. It was actually in the docs so that’s on me.
Thanks for your help

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.