Some strange errors (from users) in package, probably due to RSelenium. Any ideas?

rselenium

#1

Hi everybody, I wrote a package that scrapes data from some hockey league websites using RSelenium. Anyways, I'm on a Windows 10 computer, and everything appears to be working fine for me. The problem is that some people have tested it out for me on their computers, and they've gotten, in aggregate, a strange assortment of problems.

Do you think any of you could try it out to see if there are issues? The users who've so far tested it out are mostly beginners, so I'd love to have more experienced eyes try and use it.

You can download it with devtools::install_github("eoppe1022/chl"). There are 2 functions in the package -- get_schedule() and get_box_score(). Don't worry about persistently(). Here's my GitHub if you want to look a bit deeper into the code.

And here are some of the errors that users have seen. Any idea what I can do?

image

Thanks a ton!


#2

Well, I had mixed results. No problems on Mojave. Wouldn't compile on Ubuntu 10.14 because XML wouldn't compile. Loaded and compiled OK on Windows 10 but threw a "no Java" error when trying to connect.

This might lead to some light: https://www.java.com/en/download/faq/chrome.xml

Alternatively RSelenium/Java issues may be to blame.

Remember that scene in *Battlestar Galatica" where two Dean Stockwell characters are caught and ejected through an airlock? I'm getting to feel that way about Java and Flash. :wink:


#3

Thanks for checking it out! I'm afraid I've never seen Battlestar Galactica...

Looks like I may need to do some tinkering


#4

In case anybody missed this, I'd really appreciate it any of you tried out my package and let me know if you get any errors/what kind of errors you get. Thanks a ton.


#5

get_schedule() worked for me on Mojave - but I've configured and used RSelenium on this machine before. get_box_scores() was working, but going very slowly, so I ended the process before it scraped the data - but it appear to be working.

Hope this helps!


#6

Awesome. Thanks for checking it out. I guess I gotta figure out how I can try and configure RSelenium for people who're installing the package.