Specific packages seem to have crashed my RStudio

r

#1

Hello everyone!

First post here! I am currently working on a study for university, and needed some more packages to access more statistical formulas.

The nightmare started after trying to download "Zelig" and a lot of its dependencies which didn't install correctly (such as "pillar", "dplyr", "tibble" etc...). After some manipulations and after downloading (or trying to) the missing packages individually, I realized that a lot of them didn't work.

Error Informations:

  • installing source package 'pillar' ...
    ** package 'pillar' correctement décompressé et sommes MD5 vérifiées
    ** R
    ** preparing package for lazy loading
    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
    namespace 'rlang' 0.2.0 is being loaded, but >= 0.3.0.1 is required
    ERROR: lazy loading failed for package 'pillar'
  • removing 'C:/Users/Laurent/Documents/R/win-library/3.3/pillar'

Warning in install.packages :
installation of package ‘pillar’ had non-zero exit status

Description of issue -

Steps taken so far -
I updated all my packages before and even after downloading the new ones.
I changed the CRAN mirror a few times in case that the problem, but nothing changed.
I manually downloaded the zip files to install the packages localy instead of through CRAN.
I uninstalled RStudio and deleted the RStudio desktop file in order to restart from the scratch.

Now I can't even import a Dataset. When clicking on "Import Dataset from .." the new tab opens and an error message keeps saying that it couldn't find the package "pillar".
I am desperate and don't know what to do anymore.

I went through a few threads on the forum, and even tried to install devtools and then get pillar from Github, but even devtools can't be installed properly (through CRAN or localy).

Thanks in advance for your help.

sessionInfo()
R version 3.3.1 (2016-06-21)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

locale:
[1] LC_COLLATE=French_France.1252 LC_CTYPE=French_France.1252
[3] LC_MONETARY=French_France.1252 LC_NUMERIC=C
[5] LC_TIME=French_France.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods
[7] base

loaded via a namespace (and not attached):
[1] MASS_7.3-45 tools_3.3.1 MatchIt_3.0.2


#2

You should probably start with updating R itself. Current version is 3.5.2, so you are two major versions behind.


#3

If you update R as suggested you are going to need to reinstall (not copy/paste the libs folder as usual) all your packages also, since they need to be compiled with R >= 3.5


#4

the two comments above that basically say, "install a modern version of R and reinstall all packages" is a huge step toward solving your issue.

Just a point that may seem pedantic but will help you debug in the future: Your summary was "Specific packages seem to have crashed my RStudio". Based on your description, that's not what's happening. You are having no crashes and nothing related to RStudio. You are having trouble installing packages into R. R is the programming language and RStudio is a development environment that sits on top of R and makes it easier for you to control R.


#5

Sorry about that. Since I'm pretty much a noob here, I tried to be as clear as possible with what I thought was summarising the issue. Seems like I failed! :smiley:
I am a just post graduating economist that basically just got proud of his first 300 coding lines haha!

Thank you @mishabalyasin & andresrcs for your simple yet optimal advice. Everything worked after I updated RStudio.
When I reinstalled RStudio, I went on the rstudio website instead of cran. Big mistake!


#6

Don't feel bad! I am so sorry if that came across as critical. I wanted you to understand the difference so you could debug better. And even with this being an R problem, this is still a really good place to ask questions!

Congratulations on your first 300 lines of code!

You should read this short essay: http://varianceexplained.org/programming/bad-code/

In short, we all write a million lines of bad code. You'll write your million lines too. It's OK. That's the cost of entry.


closed #7

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.