SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert access denied

shinyappsio

#1

Hi,

getting below error while deploying the Shiny App to shinyapps.io

Error in function (type, msg, asError = TRUE) :
error:14077419:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert access denied

It happens when i am authorizing account
for e;g:

rsconnect::setAccountInfo(name='Application',
token='xxxx765fyfchjxxxxxx',
secret='566frdre4545xccxrdr')


#2

This happens most frequently when there is a proxy/firewall between your computer and shinyapps.io.

What is the current setting of the option rsconnect.http?

You might need to set the option rsconnect.ca.bundle to a certificate bundle that will validate the one used by your proxy, or as a last resort set rsconnect.check.certificate to FALSE.

See the rsconnect documentation for more information about the available options.


#3

Please see below

  • Trying 18.210.119.32...
  • Connected to api.shinyapps.io (18.210.119.32) port 443 (#0)
  • successfully set certificate verify locations:
  • CAfile: C:\Users\kakash\AppData\Local\Temp\RtmpEHyOtc\cacerts3fac6751deb.pem
    CApath: none
  • error:14077419:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert access denied
  • Closing connection 0
    Error in function (type, msg, asError = TRUE) :
    error:14077419:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert access denied
    Timing stopped at: 0.03 0.02 0.85

#4

I am quite new to the deployment.
could you please help me on this (set the option rsconnect.ca.bundle to a certificate bundle)

Thank you so much.


#5

If, in fact, you have a proxy, you will need to speak with your IT team to obtain the CA bundle they expect you to use.

Once you have obtained that, and saved it locally, options(rsconnect.ca.bundle = '<path to ca bundle you saved>') should set the option.


#6

Thanks so much Josh. it's a great help.