String Encoding Error in Notebook output

Hello! I have trouble typing code and seeing the output in Notebook.

To reproduce the problem, no need to get any data.
It occurs at any time when logging any character that is not the English alphabet.

For example, when I run the below code for the first time, the result is as follows.

library(dplyr)

It's same in the console.

image


However, if I run the same code in the console for the first time(not again, after restarting the R), it prints without any error.

image

That is, I get an error ONLY when I interact in the Notebook console.

Is there any solution to this problem?

Thank you in advance :slight_smile:


Below is my basic settings in the Notebook.

Do you see the same issue in the preview release of RStudio? We've done some work to improve how we handle different encodings on Windows in 1.4.

Thanks for taking the time to test! Would you mind filing an issue at https://github.com/rstudio/rstudio/issues, so we can try and see if we can figure out what's going on?

I reported an issue at https://github.com/rstudio/rstudio/issues/8546#issue-757940303.

Thank you!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

I've installed RStudio 1.4.1066 - Windows 10/8/7 (64-bit).

However, the same problem still occurs.