tidyverse not loading but installed succesfully. Need help.

I was able to succesfully install the tidyverse package, but when I go to import it using
library(tidyverse)
it gives this error message:
Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
namespace ‘cli’ 3.2.0 is already loaded, but >= 3.3.0 is required

This is asking you to update the cli package, give it a try

install.packages("cli")

Okay, I tried doing so with the statement you gave as well as doing it another way in r using the checkbox for cli in the bottom right corner and trying to update it but it kept trying to install it and then would ask to restart r prior to install or not restart it. I would then restart it and it would just repeat over and over. Also, if I did not restart it would update cli but it would then show my cli is not updated still and I would get the same error as before.

Okay I fixed it now. I just had R uninstall the cli package I had, and then I used the statement you gave to install it and it gave me the right version this time. Thank you so much for the help.