Webscrapping with Rvest - 'Failure when receiving data from the peer'

Hello guys,
I'm having a hard time on get R to read the content of a webpage in order to import the html tables.
Basically, I'm able to access the site on the navigator, but it seems that, as it takes too long to run, the R returns with the error bellow.
The same error doesn't happen with easier to access pages, like List of highest-grossing films - Wikipedia, for instance.
I'm using Rstudio Server 2022.02.1
I'm eager to try any workaround. Thanks in advance.


content1 <- read_html(url("http://tjj.xinjiang.gov.cn/tjj/zhhvgh/202203/9b5a616b61c54ff0826e6719fd095f20.shtml", "rb"))
#> Warning in url("http://tjj.xinjiang.gov.cn/tjj/zhhvgh/
#> 202203/9b5a616b61c54ff0826e6719fd095f20.shtml", : URL 'http://
#> tjj.xinjiang.gov.cn/tjj/zhhvgh/202203/9b5a616b61c54ff0826e6719fd095f20.shtml':
#> status was 'Failure when receiving data from the peer'
#> Error in url("http://tjj.xinjiang.gov.cn/tjj/zhhvgh/202203/9b5a616b61c54ff0826e6719fd095f20.shtml", : cannot open the connection to 'http://tjj.xinjiang.gov.cn/tjj/zhhvgh/202203/9b5a616b61c54ff0826e6719fd095f20.shtml'`

Have you tried using the verbose option? It might provide more information.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.