why is glimpse() not working

Hi there,

When I try to use glimpse(mtcars) I get the following error: 'Error in glimpse(mtcars) : could not find function "glimpse"'

I've searched help and glimpse still seems to be part of the tidyverse (dplyr, tibble) package.

Not sure why it would not be working.

Thank you for your help.

in order for glimpse to work you need to install dplyr package or tidyverse package

once you install any of them you may run the glimpse(mtcars)

Thanks @nedallo for your reply. I thought tidyverse was already installed.

When I type
install.packages(tidyverse)

I get the following error message:

Error in install.packages : object 'tidyverse' not found

install.packages() needs the name of the package to be a string in quotes.

install.packages("tidyverse") should work.

Thanks @vkatti - that worked. But when I try to load tidyverse using:

library(tidyverse)

I get the following error:

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
namespace ‘cli’ 3.2.0 is already loaded, but >= 3.3.0 is required

I tried to update Cli but get the following error message:

Error in value[3L] :
Package ‘cli’ version 3.2.0 cannot be unloaded:
Error in unloadNamespace(package) : namespace ‘cli’ is imported by ‘pillar’, ‘haven’ so cannot be unloaded

restart R session and try again. No need to install tidyverse again.

Thank @vkatti! That fixed it.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.