X2Go and Rstudio Problem: glXCreatePbuffer" when GLX 1.3 is not supported!

Hi everyone,

Fresh RHEL 7 install of latest rstudio-desktop crashes with:

qt.qpa.xcb: X server does not support XInput 2

WARNING: Application calling GLX 1.3 function "glXCreatePbuffer" when GLX 1.3 is not supported!

This is an application bug!

The server is accessed remotely via X2Go (again latest available version)

I touched base with X2Go community and the feedback I received was that RStudio developers should also be informed, since this seems to be a bug.

I have also seen this thread: X2Go and RStudio

Any suggestions for a workaround?

Thank you

Is using RStudio Server rather than RStudio Desktop an option for you in this case?

Server would be great, but I cannot figure out a secure way to open the 8787 port (it seems that ssl activation is only on Pro?). Can you point us to a primer that will help folks create a secure server?

I also have this bug. For me, the following worked:

Good luck.

I followed the advice above and the error changed to:

rstudio
qt.qpa.xcb: X server does not support XInput 2
[75893:75981:1115/182126.826541:ERROR:gl_context_egl.cc(199)] eglCreateContext failed with error EGL_BAD_MATCH
Received signal 11 SEGV_MAPERR 000000000000
#0 0x2aaab1004a4f
#1 0x2aaab1004e4b
#2 0x2aaab10054ce
#3 0x2aaab90ff5d0
#4 0x2aaaaf50d5bf
#5 0x2aaaaf50c8e9
#6 0x2aaab18d9285
#7 0x2aaab18da124
#8 0x2aaab18da471
#9 0x2aaab1e2857d
#10 0x2aaab35f3bb3
#11 0x2aaab0fde745
#12 0x2aaab1011a10
#13 0x2aaab90f7dd5 start_thread
#14 0x2aaababa1ead __clone
r8: 0000000000000001 r9: 0000000000000000 r10: 0000000000000009 r11: 0000000000000000
r12: 00002aaaedef55d0 r13: 00002aaab6067628 r14: 0000000000000000 r15: 00002aaaedef5820
di: 0000000000000000 si: 00002aab20000a10 bp: 00002aaaedef5770 bx: 00002aab20000a10
dx: 00002aab20000078 ax: 00002aaaedef55c0 cx: 00002aab200030f0 sp: 00002aaaedef55c0
ip: 00002aaaaf50d5bf efl: 0000000000010246 cgf: 0000000000000033 erf: 0000000000000004
trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.

it seems that half of the error is now gone but still no joy.

Any tips?